SMTP whitelabel

I’ve set up whitelabel and successfully tested the SMTP settings, but when I try to invite someone to a workspace, the invite email never arrives. I’ve checked in spam. Is there anything I’m missing?

Hi Fred, this should be fixed.

@Simone Great! It’s working now, thank you.

A couple of suggestions;
In the pending invites section, add a button “Resend invitation”, next to “Delete invitation”.

I would love the ability to customize outgoing email messages, so we can add out own text and your variables for dynamic data.

When adding a collaborator, an option to add first name, last name and company name etc. Now it says “Hello”… That would make for a great welcome :blush: